Ajax ASP.Net Server Problem ('Sys' is undefined.)

Share on FacebookShare on LinkedInTweet about this on TwitterShare on Google+Email this to someone
En estos dias tuve un problema a la hora de montar una aplicacion que tenia cierto elemento que usaban las librerias de Ajax ToolKit, el error que despliega esta relacionado con ‘Sys’ is undefined. La solucion que encontre fue la de agregar los siguientes elementos al Web.Config <system.webServer> <validation validateIntegratedModeConfiguration=”false”/> <modules> <add name=”ScriptModule” preCondition=”integratedMode” type=”System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″/> </modules> <handlers> <remove name=”WebServiceHandlerFactory-Integrated”/> <add name=”ScriptHandlerFactory” verb=”*” path=”*.asmx” preCondition=”integratedMode” type=”System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″/> <add name=”ScriptHandlerFactoryAppServices” verb=”*” path=”*_AppService.axd” preCondition=”integratedMode” type=”System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″/> <add name=”ScriptResource” preCondition=”integratedMode” verb=”GET,HEAD” path=”ScriptResource.axd” type=”System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″/> </handlers> </system.webServer> Con esto funciono todo muy bien :-)

Etiquetas:, , , ,

"Trackback" Enlace desde tu web.